Database tidak mau start setelah Upgrade/Patch

1 Oct

Ketika melakukan patch dari oracle 10.2.0.1 ke 10.2.0.4 pada environment oracle linux, saya menemukan error bahwa database tidak dapat dinaikkan dengan error

ORA-01092:
ORACLE instance terminated. Disconnection forced.

Hasil penyelidikan terhadap alert log,ditemukan bahwa ada error:

ORA-00704: bootstrap process failure
ORA-39700: database must be opened with UPGRADE option
Mon Jun 30 11:53:43 2008
Error 704 happened during db open, shutting down database
USER: terminating instance due to error 704
Instance terminated by USER, pid = 582062
ORA-1092 signalled during: ALTER DATABASE OPEN...

Error di atas diakibatkan karena adanya perbedaan pada dictionary setelah upgrade/patching. Dengan demikian kita perlu melakukan beberapa langkah perbaikan

Langkah-langkah untuk memperbaiki error ini adalah sebagai berikut:

  1. SQL>  startup upgrade

 

2.  Jalankan script sql berikut yang ada di direktori $ORACLE_HOME/rdbms/admin

catupgrd.sql

catalog.sql

catproc.sql

SQL> @catupgrd.sql
SQL> @catalog.sql
SQL> @catproc.sql

3. Database sudah  kembali berfungsi normal :)

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>